
MARKETING TOOLKIT



EPRI is proud to present the 

Electrification 2024 International 

Conference and Exposition, 

returning on March 12-14, 2024 in 

Savannah, Georgia — and as always, 

bringing together thought leaders 

and innovators from across the 

electrification spectrum. This event is 

where we collaborate. This is where 

we get educated. This is where we 

advance our organizations’ goals.  

This is where together, we get inspired 

and shape the future of energy.

We greatly appreciate your joining us at this event. We’re 

asking you to help spread the word so you’ll see more 

of your friends and colleagues next March in Savannah. 

This kit provides copy for your newsletter, your social 

media, your website, and event calendar — along with 

logos, graphics, banner ads, and branding guidelines. 

Within these guidelines, we encourage you to add 

your own voice and highlight your organization’s role 

at Electrification 2024, as well as your support of our 

mission and the difference an electrified future will make.

Please bookmark our website; join our mailing list for 

updates; follow EPRI on X (formerly Twitter), Facebook, 

and LinkedIn; and share any of our social media posts. 

Once again our official hashtag is #ElectricTogether.

Thank you for your support! 

The Electrification 2024 team

https://www.electrification2024.com/
https://www.electrification2024.com/cc-form
https://twitter.com/EPRINews
https://www.linkedin.com/company/epri/


@EPRINews #ElectricTogether www.electrification2024.com

MARKETING COPY

Boilerplate

EPRI’s Electrification 2024 International Conference and Expo 

returns next March 12-14, 2024, this time on the waterfront in beautiful 

Savannah, Georgia. On the theme of accelerating together for 

an electrified future, Electrification 2024 will again put you on the 

cutting edge of what’s new and what’s changed across the fields 

of electrification and decarbonization. Tracks cover all aspects, 

from electric cars, heavy trucks and buses, and low-carbon fuels; to 

greener buildings; industrial conversions; people and communities; 

the defense sector; impacts on the grid; and controlled-environment 

agriculture. Attend just one event that covers all these segments — 

designed for utilities, manufacturers, policymakers, academics, and 

community members. Register today and get ready to explore in 

depth how together we’ll meet deep decarbonization targets, and 

achieve a clean energy transition that’s focused on serving  

our customers.  

 

For details, check out EPRI’s official Electrification 2024 website.

Calendar Listing

EVENT NAME:	 Electrification 2024 International Conference & Exposition

HOST:		  EPRI

LOCATION:	 Savannah Convention Center, Savannah, Georgia

DATE:		  March 12-14, 2024

WEBSITE: 	 www.electrification2024.com

DESCRIPTION: 	 EPRI’s Electrification 2024 conference and expo returns 	

		  next March 12-14, 2024, on the waterfront in Savannah, 	

		  Georgia. On the theme of accelerating together for an 	

		  electrified future, it’s designed to keep attendees on the 	

		  cutting edge of what’s new and what’s changed across 	

		  the fields of electrification and decarbonization. Tracks 	

		  cover electric cars, heavy trucks and buses, and low 		

		  carbon fuels; greener buildings; industrial conversions; 	

		  people and communities; defense; the impact on the grid; 	

		  and controlled environment agriculture. The event 		

		  is designed for utilities, manufacturers, policymakers, 	

		  academics, and community members.  

		  Details: Electrification 2024.

https://www.electrification2024.com/
https://www.electrification2024.com/
https://www.electrification2024.com/
https://www.electrification2024.com/
http://www.electrification2024.com
https://www.electrification2024.com/
https://www.electrification2024.com/


@EPRINews #ElectricTogether www.electrification2024.com

WEB BANNER ADS

Save Images
Click on the image to launch it in a browser window. Then open the file in a PDF program and edit the footer copy appropriately.  

Any edits made to banners should be in Arial font. Export the banner as an image by going to File > Export To > Image > PNG.

Microbar 88 × 31 px

Button 2 120 × 60 px

Button 1 120 × 90 pxSpecial 2 300 x 80 px

Special 1 260 x 240 px

Wide Skyscraper  
160 × 600 px

Large Square 1080 x 1080 px

Leaderboard 728 × 90 px

Large Rectangle 336 × 280 px

Medium Rectangle 300 × 250 px

Enter message 
here

Enter message here

Enter message here Enter message here

Enter message here

Enter message here

Enter message hereEnter message here

Skyscraper  
120 × 600 px

https://www.electrification2024.com/
https://www.electrification2024.com/
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner88x31.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner120x60.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner120x90.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner300x80.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner260x240.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner1080x1080.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner336x280.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner300x250.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner728x90.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner160x600.pdf
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner120x600.pdf


@EPRINews #ElectricTogether www.electrification2024.com

LINKEDIN / GENERAL 
MARKETING POSTS
LinkedIn posts gain the most traction when released at 9-11 AM ET Tuesday, 

Wednesday and Thursday, with up to three to five hashtags. Consider 

releasing these three posts consecutively throughout the week as detailed 

above. Want to recycle these posts? No problem! Recycling posts leads to 

increased engagement, and we encourage you to post these as often as 

every 4 weeks to help spread the word!

Post 1
We’re ⚡energized⚡ about  

Electrification 2024: Join Us! 

At [Company/Organization Name], [we’re] 
[I’m] proud to be a [sponsor] [speaker] 
[exhibitor] [attendee] of the Electrification 

2024 International Conference & 

Exposition, hosted by EPRI March 12-

14 in Savannah, GA #ElectricTogether 

#Electrification2024

The conference will address the latest 

questions on electrifying numerous industry 

sectors, and explore the answers to help 

advance electrification initiatives and 

create sustainable solutions. For more 

information, check out the agenda: www.

electrification2024.com/program

⚡Register today⚡ to accelerate together 

for an electrified future

@EPRINews #ElectricTogether 

#ElectrifyEverything www.

electrification2024.com

Post 2
Want unparalleled access to industry 

influencers, compelling and insightful 

agenda sessions, a comprehensive 

exposition, and multiple networking 

functions?

[We’re] [I’m] proud to [sponsor] 
[speak as part of] [exhibit at] [attend] 
⚡Electrification 2024⚡ #ElectricTogether 

#Electrification2024 #ElectrifyEverything

Come join us for a program that covers 

industrial electrification, decarbonized 

transportation, smart buildings, 

community impacts, national defense, low 

carbon fuels, grid impacts, and indoor/

controlled environment agriculture. www.

electrification2024.com/program

You will have continuous opportunities to 

learn, share and connect in person with 

fellow industry professionals, ⚡Register 

today⚡www.electrification2024.com/

registration

@EPRINews #ElectricTogether 

#ElectrifyEverything  

www.electrification2024.com

Post 3
We can’t wait to meet you in person at 

upcoming ⚡Electrification 2024⚡!

As a [sponsor] [speaker] [exhibitor] 
[attendee], Electrification 2024 helps 

[us] [me] stay at the forefront of how 

we access our energy. Connect with 

us at the conference and help expand 

electrification’s significant benefits.

Interested? For full details, including 

agenda, registration, exhibit, and 

sponsorship opportunities, visit www.

electrification2024.com.

⚡Register today⚡ to accelerate  

together for an electrified future.  

www.electrification2024.com/registration 

@EPRINews #ElectricTogether 

#ElectrifyEverything

Post 4
#ElectricTogether is not just a  

slogan — at Electrification 2024 we’re 

diving deep into how our electrified  

future can deliver economic benefits to 

empower local communities and uplift  

all segments of society.

As a [sponsor] [speaker] [exhibitor] 
[attendee], Electrification 2024 helps  

[us] [me] see the full picture of electrification 

and how it will help us solve global 

challenges like climate change while 

reducing inequities at the community level.

For more information, check out the 

agenda: www.electrification2024.com/

program

⚡Register today⚡ to accelerate together 

for an electrified future for an electrified 

world tomorrow

@EPRINews #ElectricTogether 

#ElectrifyEverything  

www.electrification2024.com

Please consider adding this banner for each  
LinkedIn post. 

Save Image
Click on the image to launch it in a browser window.  

Then open the file in a PDF program and edit the footer 

copy appropriately. Any edits made to banners should be in 

Arial font. Export the banner as an image by going to File > 
Export To > Image > PNG.

Enter message here

https://www.electrification2024.com/
https://www.electrification2024.com/
https://www.linkedin.com/pulse/increase-engagement-recycling-your-top-social-media-victoria-lee-/
https://www.linkedin.com/pulse/increase-engagement-recycling-your-top-social-media-victoria-lee-/
http://www.electrification2024.com/program 
http://www.electrification2024.com/program 
http://www.electrification2024.com
http://www.electrification2024.com
http://www.electrification2024.com/program
http://www.electrification2024.com/program
http://www.electrification2024.com/registration
http://www.electrification2024.com/registration
http://www.electrification2024.com
http://www.electrification2024.com
http://www.electrification2024.com
http://www.electrification2024.com/registration 
http://www.electrification2024.com/program 
http://www.electrification2024.com/program 
http://www.electrification2024.com
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner250x300.pdf


@EPRINews #ElectricTogether www.electrification2024.com

TWITTER POSTS
Twitter posts gain the most traction when released between 9-11 

AM ET or between 6-9 PM ET. Consider releasing these three posts 

consecutively throughout the week during the times above. Want to 

recycle these posts? No problem! Recycling posts leads to increased 

engagement, and we encourage you to post these as often as every 

4 weeks to help spread the word!

Post 1
[We’re] [I’m] proud to [sponsor] [speak 
at] [exhibit at] [attend] @EPRINews’ 

Electrification 2024! #ElectricTogether

Tracks cover industry, transportation, 

buildings, communities, defense, 

electrofuels, transmission, and agriculture. 

Register today at electrification2024.com

Post 2
[We’re] [I’m] ⚡energized⚡ to [sponsor] 
[speak at] [exhibit at] [attend]  
@EPRINews’ Electrification 2024 

conference March 12-14 in Savannah, 

GA. Connect with other leaders working 

to #electrify and #decarbonize our 

society. Register today! #ElectricTogether 

electrification2024.com

Post 3
This year [we are] [I am] thrilled 

to [sponsor] [speak at] [exhibit at] 
[attend] @EPRINews’ Electrification 

2024! Come connect in person with 

the leaders working for a future of 

#electrification and #decarbonization. 

⚡Register today⚡ #ElectricTogether 

electrification2024.com

Post 4
[We’re] [I’m] proud to [sponsor] 
[speak at] [exhibit at] [attend] @
EPRINews’ Electrification 2024 

conference March 12-14 in Savannah, 

GA. This year’s program includes a 

new track on how electrification can 

empower local communities and uplift 

society equitably. #ElectricTogether 

electrification2024.com

Please consider adding this banner for each Twitter 
post. Up to 4 images can be added to each post, so we 
encourage you to add both this banner and an image 
of your organization.

Save Image
Click on the image to launch it in a browser window.  

Then open the file in a PDF program and edit the footer 

copy appropriately. Any edits made to banners should be in 

Arial font. Export the banner as an image by going to File > 
Export To > Image > PNG.

Enter message here

https://www.electrification2024.com/
https://www.electrification2024.com/
https://www.linkedin.com/pulse/increase-engagement-recycling-your-top-social-media-victoria-lee-/
https://www.linkedin.com/pulse/increase-engagement-recycling-your-top-social-media-victoria-lee-/
http://electrification2024.com
http://electrification2024.com
http://electrification2024.com
http://electrification2024.com
https://www.electrification2024.com/images/media/toolkit/E-2024-Banner250x300.pdf


Thank you again for your support of 

the Electrification 2024 International 

Conference & Exposition.

For questions or more information  

about this marketing toolkit, contact  

our Communications Manager,  

Samantha Gilman, at SGilman@epri.com.

mailto:SGilman%40epri.com?subject=

